aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-12-02 16:41:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-12-02 16:41:03 +0000
commit3fab0ab03ffebf980a4582b3c4a54d4fb6a74c08 (patch)
tree89cfa70014c554c8753782fab558317974e838ee /package/kernel/mac80211/Makefile
parentfed8a06b41e0972b0cd25036eaa411f34397debc (diff)
downloadmaster-187ad058-3fab0ab03ffebf980a4582b3c4a54d4fb6a74c08.tar.gz
master-187ad058-3fab0ab03ffebf980a4582b3c4a54d4fb6a74c08.tar.bz2
master-187ad058-3fab0ab03ffebf980a4582b3c4a54d4fb6a74c08.zip
netifd: add wireless configuration support and port mac80211 to the new framework
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38988 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index aafa28bd1e..21b8bb517c 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -72,7 +72,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211 +hostapd-common
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
@@ -1537,8 +1537,9 @@ define KernelPackage/libertas-sd/install
endef
define KernelPackage/cfg80211/install
- $(INSTALL_DIR) $(1)/lib/wifi
+ $(INSTALL_DIR) $(1)/lib/wifi $(1)/lib/netifd/wireless
$(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi
+ $(INSTALL_BIN) ./files/lib/netifd/wireless/mac80211.sh $(1)/lib/netifd/wireless
endef
define KernelPackage/p54-pci/install