aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-27 20:44:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-09-27 20:44:11 +0000
commit3c37470f31ccf393415347b4c5ce6558491c644a (patch)
treedeb25d57062eb6780c05e0f94fbdbbae4a3f9418 /package/kernel/linux
parent2311f0163e722d9c25db14426328e9ba11ea4ff9 (diff)
downloadmaster-187ad058-3c37470f31ccf393415347b4c5ce6558491c644a.tar.gz
master-187ad058-3c37470f31ccf393415347b4c5ce6558491c644a.tar.bz2
master-187ad058-3c37470f31ccf393415347b4c5ce6558491c644a.zip
kernel: mark kmod-thermal menuconfig symbol as hidden to avoid building it on targets with no thermal drivers
Should fix build errors with Linux 3.3/3.6 targets, which use different kconfig symbols Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38238 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cbce02bbf5..b3e268e79c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -765,6 +765,7 @@ $(eval $(call KernelPackage,random-core))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
+ HIDDEN:=1
KCONFIG:= \
CONFIG_THERMAL \
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \