aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-12 16:26:55 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-12 16:26:55 +0000
commit749ec9639b6a06281ab379bc3c8bfb6bd0369ce7 (patch)
tree57c852a8130f3b9ecded048f2a3c158776adb6d4 /package/kernel/linux/modules
parent40b24c43f07f67aba2f7f7479951f45ae6a32254 (diff)
downloadmaster-187ad058-749ec9639b6a06281ab379bc3c8bfb6bd0369ce7.tar.gz
master-187ad058-749ec9639b6a06281ab379bc3c8bfb6bd0369ce7.tar.bz2
master-187ad058-749ec9639b6a06281ab379bc3c8bfb6bd0369ce7.zip
kernel: add kirkwood thermal module
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38371 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 65f2975a2b..453bedfc20 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -824,3 +824,20 @@ define KernelPackage/thermal-imx/description
endef
$(eval $(call KernelPackage,thermal-imx))
+
+
+define KernelPackage/thermal-kirkwood
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Temperature sensor on Marvell Kirkwood SoCs
+ DEPENDS:=@TARGET_kirkwood +kmod-thermal
+ KCONFIG:=CONFIG_KIRKWOOD_THERMAL
+ FILES:=$(LINUX_DIR)/drivers/thermal/kirkwood_thermal.ko
+ AUTOLOAD:=$(call AutoProbe,kirkwood_thermal)
+endef
+
+define KernelPackage/thermal-kirkwood/description
+ Support for the Kirkwood thermal sensor driver into the Linux thermal
+ framework. Only kirkwood 88F6282 and 88F6283 have this sensor.
+endef
+
+$(eval $(call KernelPackage,thermal-kirkwood))