aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-03-20 23:15:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-03-20 23:15:56 +0000
commit0b8f6c7be858697039bd8289dff2e169fa7b4406 (patch)
tree0d93822f447af1d79c9ef5f4dcfe620565ae48a6 /package/kernel/linux/modules/sound.mk
parente2341f8361eeef035b2627a5b5e20fc91ac08e6d (diff)
downloadmaster-187ad058-0b8f6c7be858697039bd8289dff2e169fa7b4406.tar.gz
master-187ad058-0b8f6c7be858697039bd8289dff2e169fa7b4406.tar.bz2
master-187ad058-0b8f6c7be858697039bd8289dff2e169fa7b4406.zip
modules: make kmod-pcspkr depend on X86
The kernel Kconfig dependency lists X86, and we will fail building this module on other platforms such as Malta. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39974 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 777d274a4e..ebdd3d9fe3 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -262,7 +262,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
define KernelPackage/pcspkr
- DEPENDS:=@!TARGET_x86
+ DEPENDS:=@TARGET_x86
TITLE:=PC speaker support
KCONFIG:= \
CONFIG_INPUT_PCSPKR \