aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-adsl-fw/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-24 16:39:07 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 16:39:07 +0200
commit1520c5ac9519ebc16903af665d6dc5c88c20d5a9 (patch)
tree1dca005181bc381b237d718d64bc1a331114d3d4 /package/kernel/lantiq/ltq-adsl-fw/Makefile
parentf99a37fae31a0a79496d567ea2aa870ace615a14 (diff)
downloadmaster-187ad058-1520c5ac9519ebc16903af665d6dc5c88c20d5a9.tar.gz
master-187ad058-1520c5ac9519ebc16903af665d6dc5c88c20d5a9.tar.bz2
master-187ad058-1520c5ac9519ebc16903af665d6dc5c88c20d5a9.zip
package/lantiq: make lantiq kernel modules work with xway_legacy
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-adsl-fw/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-adsl-fw/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/kernel/lantiq/ltq-adsl-fw/Makefile b/package/kernel/lantiq/ltq-adsl-fw/Makefile
index a26e595023..839ae715fe 100644
--- a/package/kernel/lantiq/ltq-adsl-fw/Makefile
+++ b/package/kernel/lantiq/ltq-adsl-fw/Makefile
@@ -30,15 +30,15 @@ define Package/kmod-ltq-adsl-fw-template
SOC:=$(2)
ANNEX:=$(1)
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_$(3) +kmod-ltq-adsl-$(2)
+ DEPENDS:=@$(3) +kmod-ltq-adsl-$(2)
endef
-Package/kmod-ltq-adsl-danube-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,danube,xway)
-Package/kmod-ltq-adsl-danube-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,danube,xway)
-Package/kmod-ltq-adsl-ar9-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,ar9,xway)
-Package/kmod-ltq-adsl-ar9-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,ar9,xway)
-Package/kmod-ltq-adsl-ase-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,ase,ase)
-Package/kmod-ltq-adsl-ase-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,ase,ase)
+Package/kmod-ltq-adsl-danube-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
+Package/kmod-ltq-adsl-danube-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
+Package/kmod-ltq-adsl-ar9-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,ar9,TARGET_lantiq_xway)
+Package/kmod-ltq-adsl-ar9-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,ar9,TARGET_lantiq_xway)
+Package/kmod-ltq-adsl-ase-fw-a=$(call Package/kmod-ltq-adsl-fw-template,a,ase,TARGET_lantiq_ase)
+Package/kmod-ltq-adsl-ase-fw-b=$(call Package/kmod-ltq-adsl-fw-template,b,ase,TARGET_lantiq_ase)
define Build/Compile
endef