aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
committerHamish Guthrie <hcg@openwrt.org>2012-10-19 15:34:28 +0000
commita81ef914e0b41afc1dfd4292b8352e33f22dde22 (patch)
tree456cb3e98620d4ff6318a6e23ad37b6144ccda4c /package/kernel/Makefile
parent810db7487c02e232e792c5a6dffdb4aac044615b (diff)
downloadmaster-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.gz
master-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.tar.bz2
master-187ad058-a81ef914e0b41afc1dfd4292b8352e33f22dde22.zip
licensing: Add licensing metadata to many packages
Two new variables are introduces to many packages, namely PKG_LICENSE and PKG_LICENSE_FILES - there may be more than one license applied to packages, and these are listed in the PKG_LICENSE variable and separated by spaces. All relevant license files are also added to the PKG_LICENSE_FILES variable, also space separated. The licensing metadata is put into the bin/<platform>/packages/Packages file for later parsing. A script for that is on it's way! git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33861 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/Makefile')
-rw-r--r--package/kernel/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index 8050817392..d44b5a7767 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -14,6 +14,9 @@ PKG_FLAGS:=hold
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
ifeq ($(DUMP),)
-include $(LINUX_DIR)/.config