aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-05-27 05:58:23 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-05-27 05:58:23 +0000
commit11fdfdc22aa046548d09d134e2d104427ab39b11 (patch)
treefede367e04e804dc4fda3fa73d79fdb1e0e4f4d2 /package/iptables
parent104fad8310d73b784569f298bd5b28cfc2ff449d (diff)
downloadmaster-187ad058-11fdfdc22aa046548d09d134e2d104427ab39b11.tar.gz
master-187ad058-11fdfdc22aa046548d09d134e2d104427ab39b11.tar.bz2
master-187ad058-11fdfdc22aa046548d09d134e2d104427ab39b11.zip
ipcontrack is a module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1079 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/kernelconfig.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/iptables/kernelconfig.mk b/package/iptables/kernelconfig.mk
index 00d2349aa3..a0b420f198 100644
--- a/package/iptables/kernelconfig.mk
+++ b/package/iptables/kernelconfig.mk
@@ -17,23 +17,23 @@ ext-$(CONFIG_IP_NF_MATCH_LENGTH) += length
ext-$(CONFIG_IP_NF_MATCH_TTL) += ttl
ext-$(CONFIG_IP_NF_MATCH_TCPMSS) += tcpmss
ext-$(CONFIG_IP_NF_MATCH_HELPER) += helper
-ext-$(CONFIG_IP_NF_MATCH_STATE) += state
-ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
+#ext-$(CONFIG_IP_NF_MATCH_STATE) += state
+#ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
ext-$(CONFIG_IP_NF_MATCH_UNCLEAN) += unclean
ext-$(CONFIG_IP_NF_MATCH_OWNER) += owner
ext-$(CONFIG_IP_NF_MATCH_PHYSDEV) += physdev
ext-$(CONFIG_IP_NF_MATCH_LAYER7) += layer7
-ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
+#ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
ext-$(CONFIG_IP_NF_TARGET_REDIRECT) += REDIRECT
ext-$(CONFIG_IP_NF_TARGET_REJECT) += REJECT
ext-$(CONFIG_IP_NF_TARGET_TOS) += TOS
ext-$(CONFIG_IP_NF_TARGET_ECN) += ECN
ext-$(CONFIG_IP_NF_TARGET_DSCP) += DSCP
ext-$(CONFIG_IP_NF_TARGET_MARK) += MARK
-ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
+#ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
ext-$(CONFIG_IP_NF_TARGET_ULOG) += ULOG
-ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
+#ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
# add extensions that don't depend on kernel config
ext-m += TTL
-ext-y += icmp standard tcp udp
+ext-y += icmp standard tcp udp state MASQUERADE conntrack TCPMSS LOG