aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables/patches/001-ipp2p-0.8.1rc1.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-04 11:25:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-04 11:25:53 +0000
commit12a81e859f38f85f5143e72b56b5a1f974c53576 (patch)
treeb2d994878969d3f9d2d56625fccda64c5ac25e8a /package/iptables/patches/001-ipp2p-0.8.1rc1.patch
parentac587815b0f46cdc8eb7d7141ffb5784b98b4b3b (diff)
downloadmaster-187ad058-12a81e859f38f85f5143e72b56b5a1f974c53576.tar.gz
master-187ad058-12a81e859f38f85f5143e72b56b5a1f974c53576.tar.bz2
master-187ad058-12a81e859f38f85f5143e72b56b5a1f974c53576.zip
refresh all package patches in the buildroot using quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7490 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables/patches/001-ipp2p-0.8.1rc1.patch')
-rw-r--r--package/iptables/patches/001-ipp2p-0.8.1rc1.patch27
1 files changed, 15 insertions, 12 deletions
diff --git a/package/iptables/patches/001-ipp2p-0.8.1rc1.patch b/package/iptables/patches/001-ipp2p-0.8.1rc1.patch
index f7129b4560..06397410bc 100644
--- a/package/iptables/patches/001-ipp2p-0.8.1rc1.patch
+++ b/package/iptables/patches/001-ipp2p-0.8.1rc1.patch
@@ -1,9 +1,10 @@
-diff -urN iptables.old/extensions/Makefile iptables.dev/extensions/Makefile
---- iptables.old/extensions/Makefile 2005-07-20 04:22:56.000000000 +0200
-+++ iptables.dev/extensions/Makefile 2006-03-23 14:42:28.000000000 +0100
-@@ -8,6 +8,10 @@
- PF_EXT_SLIB:=ah addrtype comment connlimit connmark conntrack dscp ecn esp hashlimit helper icmp iprange length limit mac mark multiport owner physdev pkttype realm rpc sctp standard state tcp tcpmss tos ttl udp unclean CLASSIFY CONNMARK DNAT DSCP ECN LOG MARK MASQUERADE MIRROR NETMAP NFQUEUE NOTRACK REDIRECT REJECT SAME SNAT TARPIT TCPMSS TOS TRACE TTL ULOG
- PF6_EXT_SLIB:=eui64 hl icmpv6 length limit mac mark multiport owner physdev standard tcp udp HL LOG NFQUEUE MARK TRACE
+Index: iptables-1.3.7/extensions/Makefile
+===================================================================
+--- iptables-1.3.7.orig/extensions/Makefile 2007-06-04 13:21:43.398379112 +0200
++++ iptables-1.3.7/extensions/Makefile 2007-06-04 13:21:43.484366040 +0200
+@@ -13,6 +13,10 @@
+ PF6_EXT_SE_SLIB:=SECMARK CONNSECMARK
+ endif
+
+# ipp2p
@@ -12,9 +13,10 @@ diff -urN iptables.old/extensions/Makefile iptables.dev/extensions/Makefile
# Optionals
PF_EXT_SLIB_OPTS:=$(foreach T,$(wildcard extensions/.*-test),$(shell KERNEL_DIR=$(KERNEL_DIR) $(T)))
PF6_EXT_SLIB_OPTS:=$(foreach T,$(wildcard extensions/.*-test6),$(shell KERNEL_DIR=$(KERNEL_DIR) $(T)))
-diff -urN iptables.old/extensions/libipt_ipp2p.c iptables.dev/extensions/libipt_ipp2p.c
---- iptables.old/extensions/libipt_ipp2p.c 1970-01-01 01:00:00.000000000 +0100
-+++ iptables.dev/extensions/libipt_ipp2p.c 2006-03-23 14:43:26.000000000 +0100
+Index: iptables-1.3.7/extensions/libipt_ipp2p.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ iptables-1.3.7/extensions/libipt_ipp2p.c 2007-06-04 13:21:43.485365888 +0200
@@ -0,0 +1,401 @@
+
+#include <stdio.h>
@@ -417,9 +419,10 @@ diff -urN iptables.old/extensions/libipt_ipp2p.c iptables.dev/extensions/libipt_
+ register_match(&ipp2p);
+}
+
-diff -urN iptables.old/include/linux/netfilter_ipv4/ipt_ipp2p.h iptables.dev/include/linux/netfilter_ipv4/ipt_ipp2p.h
---- iptables.old/include/linux/netfilter_ipv4/ipt_ipp2p.h 1970-01-01 01:00:00.000000000 +0100
-+++ iptables.dev/include/linux/netfilter_ipv4/ipt_ipp2p.h 2006-03-23 14:44:26.000000000 +0100
+Index: iptables-1.3.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ iptables-1.3.7/include/linux/netfilter_ipv4/ipt_ipp2p.h 2007-06-04 13:21:43.485365888 +0200
@@ -0,0 +1,31 @@
+#ifndef __IPT_IPP2P_H
+#define __IPT_IPP2P_H