aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
commit0f48fd8058bcf04e24ce149e16cca767a3652806 (patch)
treeed3b2eca81c314c2fbcb5b4e7f4159b709630bf3 /package/hostapd
parentfbf1d97b4a6d248b22dd6fddb09798855d8ae951 (diff)
downloadmaster-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.tar.gz
master-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.tar.bz2
master-187ad058-0f48fd8058bcf04e24ce149e16cca767a3652806.zip
build variants: only build opkg packages for the requested build variant (or any if no variant was specified for the package)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18464 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 5e10ea27b9..bb497fec3b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -108,7 +108,7 @@ define Build/Compile
hostapd hostapd_cli
endef
-define Package/InstallTemplate
+define Package/hostapd/install
$(INSTALL_DIR) $(1)/etc/hotplug.d/net
$(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
$(INSTALL_DIR) $(1)/lib/wifi
@@ -116,12 +116,7 @@ define Package/InstallTemplate
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
endef
-
-ifeq ($(BUILD_VARIANT),full)
- Package/hostapd/install = $(Package/InstallTemplate)
-else
- Package/hostapd-mini/install = $(Package/InstallTemplate)
-endif
+Package/hostapd-mini/install = $(Package/hostapd/install)
define Package/hostapd-utils/install
$(INSTALL_DIR) $(1)/usr/sbin