aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
commit07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d (patch)
tree090bd23485a06b25d7416926be7177c9bf4b91e5 /package/hostapd/Makefile
parentef588da41619ad44fd9ba4daafc4ee02ba17d9a1 (diff)
downloadmaster-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.tar.gz
master-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.tar.bz2
master-187ad058-07f45e3a7d16b94f0ef2c5e7e04f111c408cdf8d.zip
introduce a generic PKG_CONFIG_DEPENDS for packages that need to be reconfigured when certain CONFIG options changed, rename PKG_BUILD_DEPEND to PKG_BUILD_DEPENDS
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15451 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 4955979309..0c1d6fc776 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -16,18 +16,20 @@ PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_MD5SUM:=83630d11fa66ade9091f1b304fccd74c
-PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi PACKAGE_kmod-mac80211:mac80211 PACKAGE_kmod-mac80211:libnl
-include $(INCLUDE_DIR)/package.mk
+PKG_BUILD_DEPENDS:= \
+ PACKAGE_kmod-madwifi:madwifi \
+ PACKAGE_kmod-mac80211:mac80211 \
+ PACKAGE_kmod-mac80211:libnl \
-PKG_CONFDEPS := \
+PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-ath9k \
CONFIG_PACKAGE_kmod-mac80211 \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
- CONFIG_PACKAGE_hostapd-mini
+ CONFIG_PACKAGE_hostapd-mini \
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,$(PKG_CONFDEPS))
+include $(INCLUDE_DIR)/package.mk
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \