aboutsummaryrefslogtreecommitdiffstats
path: root/package/ead/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-25 03:30:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-25 03:30:20 +0000
commit44ccebc33f97bbb729822249ed6de790d3180687 (patch)
tree65d72a18ad8ada321bdf9e0accfd57af3a31fd84 /package/ead/Makefile
parent25bf9db38981cc8a0800e0b9c5751c2468c52339 (diff)
downloadmaster-187ad058-44ccebc33f97bbb729822249ed6de790d3180687.tar.gz
master-187ad058-44ccebc33f97bbb729822249ed6de790d3180687.tar.bz2
master-187ad058-44ccebc33f97bbb729822249ed6de790d3180687.zip
ead: use the new pcap features and the raw socket optimization to eliminate most of the cpu utilization overhead caused by the use of pcap live capturing
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15400 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ead/Makefile')
-rw-r--r--package/ead/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/ead/Makefile b/package/ead/Makefile
index 0ecff2a8ed..958577ff90 100644
--- a/package/ead/Makefile
+++ b/package/ead/Makefile
@@ -11,8 +11,10 @@ PKG_NAME:=ead
PKG_RELEASE:=1
PKG_BUILD_DEPENDS:=libpcap
+PKG_BUILD_DIR:=$(BUILD_DIR)/ead
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
define Package/ead
SECTION:=net
@@ -29,6 +31,7 @@ endef
CONFIGURE_PATH = tinysrp
TARGET_CFLAGS += \
+ -I$(LINUX_DIR)/include \
-I$(PKG_BUILD_DIR) \
-I$(PKG_BUILD_DIR)/tinysrp \
$(TARGET_CPPFLAGS)