aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/trace-cmd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-11-27 18:08:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-11-27 18:08:42 +0000
commit19cfe5300b67f31dcd96b36a3d427254c8080c41 (patch)
tree83b542e3d6053766bb5041a58a371952937cb990 /package/devel/trace-cmd/Makefile
parent11df5c8068a292c9d22288fb44f803ca12673aa7 (diff)
downloadmaster-187ad058-19cfe5300b67f31dcd96b36a3d427254c8080c41.tar.gz
master-187ad058-19cfe5300b67f31dcd96b36a3d427254c8080c41.tar.bz2
master-187ad058-19cfe5300b67f31dcd96b36a3d427254c8080c41.zip
trace-cmd: lazily evaluate extra plugins list, fixes stray build errors causing by missing operands to cp if the package was never built yet
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34390 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel/trace-cmd/Makefile')
-rw-r--r--package/devel/trace-cmd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/devel/trace-cmd/Makefile b/package/devel/trace-cmd/Makefile
index c201eb0ecd..1d555db4d4 100644
--- a/package/devel/trace-cmd/Makefile
+++ b/package/devel/trace-cmd/Makefile
@@ -35,9 +35,7 @@ MAKE_FLAGS += \
prefix=/usr
PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
-PLUGINS_ALL = $(patsubst $(PLUGINS_DIR)/plugin_%.so,%,$(wildcard $(PLUGINS_DIR)/plugin_*.so))
PLUGINS_MAIN := function hrtimer mac80211 sched_switch
-PLUGINS_EXTRA = $(filter-out $(PLUGINS_MAIN),$(PLUGINS_ALL))
TARGET_CFLAGS += --std=gnu99
@@ -52,7 +50,10 @@ endef
define Package/trace-cmd-extra/install
$(INSTALL_DIR) $(1)/usr/lib/trace-cmd/plugins
$(CP) \
- $(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_EXTRA)) \
+ $$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
+ $$(filter-out $(PLUGINS_MAIN), \
+ $$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
+ $$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
$(1)/usr/lib/trace-cmd/plugins
endef