aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/perf/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-02 14:47:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-02 14:47:57 +0000
commita458906480ad9baeffe22783319632aede4d4668 (patch)
treee3272886dde80cbabdbea3816480a07379c59e95 /package/devel/perf/Makefile
parentbc33de524ebe39f357f15ca497701bb2dd9b38ca (diff)
downloadmaster-187ad058-a458906480ad9baeffe22783319632aede4d4668.tar.gz
master-187ad058-a458906480ad9baeffe22783319632aede4d4668.tar.bz2
master-187ad058-a458906480ad9baeffe22783319632aede4d4668.zip
perf: fix musl compatibility
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48067 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel/perf/Makefile')
-rw-r--r--package/devel/perf/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index d6db053173..c999229324 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+ DEPENDS:= @!USE_UCLIBC +libelf1 +libdw +libpthread +librt +binutils
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
@@ -57,6 +57,10 @@ MAKE_FLAGS = \
WERROR=0 \
prefix=/usr
+ifdef CONFIG_USE_MUSL
+ MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
+
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
-C $(PKG_BUILD_DIR) \