aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-16 10:42:10 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-16 10:42:10 +0000
commite5127b11a83ed3e7b3ec3c4522d8ad4464777ec9 (patch)
tree8644dfb7b39f55191dd9997f7a7d2bc5996682d7 /package/busybox
parent6d3fdb1415b571951c7449a455591963b8b3f28e (diff)
downloadmaster-187ad058-e5127b11a83ed3e7b3ec3c4522d8ad4464777ec9.tar.gz
master-187ad058-e5127b11a83ed3e7b3ec3c4522d8ad4464777ec9.tar.bz2
master-187ad058-e5127b11a83ed3e7b3ec3c4522d8ad4464777ec9.zip
package/busybox: rename 'target-config.in' to 'Config.in' for coherency, move submenu to it and source main busybox Config.in from there
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20912 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Config.in (renamed from package/busybox/target-config.in)6
-rw-r--r--package/busybox/Makefile6
2 files changed, 7 insertions, 5 deletions
diff --git a/package/busybox/target-config.in b/package/busybox/Config.in
index b06556134e..1002a5a0d6 100644
--- a/package/busybox/target-config.in
+++ b/package/busybox/Config.in
@@ -1,3 +1,6 @@
+menu "Configuration"
+ depends on PACKAGE_busybox
+
config BUSYBOX_CONFIG_FEATURE_DEVFS
bool
default y if LINUX_2_4
@@ -31,3 +34,6 @@ config BUSYBOX_CONFIG_HUSH
default y if NOMMU
default n if !NOMMU
+source "package/busybox/config/Config.in"
+
+endmenu
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 9638e9c5f2..d13980ceb0 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -42,11 +42,7 @@ define Package/busybox/description
endef
define Package/busybox/config
- menu "Configuration"
- depends on PACKAGE_busybox
- source "$(SOURCE)/target-config.in"
- source "$(SOURCE)/config/Config.in"
- endmenu
+ source "$(SOURCE)/Config.in"
endef
define Build/Configure