aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-15 17:38:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-15 17:38:55 +0000
commit7be583d9f4f6e1e9c336104e3b29bd19fa5a2067 (patch)
tree349bb62bd9b99a0e51095bfb27d55fff958771d9 /package/busybox/Makefile
parent5891c99757cbe9e9c322c6e9c5f903481ac44dde (diff)
downloadmaster-187ad058-7be583d9f4f6e1e9c336104e3b29bd19fa5a2067.tar.gz
master-187ad058-7be583d9f4f6e1e9c336104e3b29bd19fa5a2067.tar.bz2
master-187ad058-7be583d9f4f6e1e9c336104e3b29bd19fa5a2067.zip
[package] busybox: fix hexdump segmentation fault with an empty leading format unit
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29156 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 967fa75dd1..7989345466 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -72,6 +72,8 @@ ifdef CONFIG_BUSYBOX_USE_LIBRPC
LDLIBS += rpc
endif
+TARGET_CFLAGS += -ggdb3
+
define Build/Compile
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \