aboutsummaryrefslogtreecommitdiffstats
path: root/package/br2684ctl/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-01-29 02:14:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-01-29 02:14:22 +0000
commit338276cab2da6df653d5506bc3f89732e35f727e (patch)
treec23990225ffe1c15ec4aa8419cb523f96ed90ca5 /package/br2684ctl/Makefile
parent57fd328159ed0039352f8b2e5d90ce8eea11b90d (diff)
downloadmaster-187ad058-338276cab2da6df653d5506bc3f89732e35f727e.tar.gz
master-187ad058-338276cab2da6df653d5506bc3f89732e35f727e.tar.bz2
master-187ad058-338276cab2da6df653d5506bc3f89732e35f727e.zip
[package] br2684ctl from linux-atm
Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25225 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/br2684ctl/Makefile')
-rw-r--r--package/br2684ctl/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/package/br2684ctl/Makefile b/package/br2684ctl/Makefile
deleted file mode 100644
index f8bf4aea29..0000000000
--- a/package/br2684ctl/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=br2684ctl
-PKG_VERSION:=20040226
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
-PKG_MD5SUM:=6eb4d8cd174e24a7c078eb4f594f5b69
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
-PKG_BUILD_DEPENDS:=linux-atm
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- SECTION:=net
- CATEGORY:=Base system
- TITLE:=ATM Ethernet bridging configuration utility
- DEPENDS:=+linux-atm
- URL:=http://ftp.debian.org/debian/pool/main/b/br2684ctl
-endef
-
-TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
-MAKE_FLAGS += CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)"
-
-define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,$(PKG_NAME)))