aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-xburst/files/board/nanonote
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2013-01-07 14:10:01 +0000
committerMirko Vogt <mirko@openwrt.org>2013-01-07 14:10:01 +0000
commit130b30fbba55d2da7582986f7a5b90bbdfb9a66e (patch)
treee6bbb4cc46961482fff071b74e8666cefe5e5206 /package/boot/uboot-xburst/files/board/nanonote
parent16b08bfc594cff67e02fd1931ee137db754d5cab (diff)
downloadmaster-187ad058-130b30fbba55d2da7582986f7a5b90bbdfb9a66e.tar.gz
master-187ad058-130b30fbba55d2da7582986f7a5b90bbdfb9a66e.tar.bz2
master-187ad058-130b30fbba55d2da7582986f7a5b90bbdfb9a66e.zip
This patch updates uboot-xburst from 2009.11 to 2012.10-rc2 - Ingenic SoC support went upstream
Summary: * remove all files/* (since merged to upstream) * patches on nand-spl, mmc and lcd driver Thanks a lot to Xiangfu Liu! Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35034 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-xburst/files/board/nanonote')
-rw-r--r--package/boot/uboot-xburst/files/board/nanonote/Makefile38
-rw-r--r--package/boot/uboot-xburst/files/board/nanonote/config.mk31
-rw-r--r--package/boot/uboot-xburst/files/board/nanonote/nanonote.c123
-rw-r--r--package/boot/uboot-xburst/files/board/nanonote/u-boot-nand.lds63
-rw-r--r--package/boot/uboot-xburst/files/board/nanonote/u-boot.lds63
5 files changed, 0 insertions, 318 deletions
diff --git a/package/boot/uboot-xburst/files/board/nanonote/Makefile b/package/boot/uboot-xburst/files/board/nanonote/Makefile
deleted file mode 100644
index 2c726a788b..0000000000
--- a/package/boot/uboot-xburst/files/board/nanonote/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# (C) Copyright 2006
-# Ingenic Semiconductor, <jlwei@ingenic.cn>
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of
-# the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-# MA 02111-1307 USA
-#
-
-include $(TOPDIR)/config.mk
-
-LIB = lib$(BOARD).a
-
-OBJS = $(BOARD).o
-SOBJS =
-
-$(LIB): .depend $(OBJS) $(SOBJS)
- $(AR) crv $@ $(OBJS) $(SOBJS)
-
-#########################################################################
-
-.depend: Makefile $(SOBJS:.o=.S) $(OBJS:.o=.c)
- $(CC) -M $(CFLAGS) $(SOBJS:.o=.S) $(OBJS:.o=.c) > $@
-
-sinclude .depend
-
-#########################################################################
diff --git a/package/boot/uboot-xburst/files/board/nanonote/config.mk b/package/boot/uboot-xburst/files/board/nanonote/config.mk
deleted file mode 100644
index 858e6a2f9d..0000000000
--- a/package/boot/uboot-xburst/files/board/nanonote/config.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# (C) Copyright 2006 Qi Hardware, Inc.
-# Author: Xiangfu Liu <xiangfu.z@gmail.com>
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of
-# the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-# MA 02111-1307 USA
-#
-
-#
-# Qi Hardware, Inc. Ben NanoNote (QI_LB60)
-#
-
-ifndef TEXT_BASE
-# ROM version
-# TEXT_BASE = 0x88000000
-
-# RAM version
-TEXT_BASE = 0x80100000
-endif
diff --git a/package/boot/uboot-xburst/files/board/nanonote/nanonote.c b/package/boot/uboot-xburst/files/board/nanonote/nanonote.c
deleted file mode 100644
index 96a3c7da00..0000000000
--- a/package/boot/uboot-xburst/files/board/nanonote/nanonote.c
+++ /dev/null
@@ -1,123 +0,0 @@
-/*
- * Authors: Xiangfu Liu <xiangfu.z@gmail.com>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * as published by the Free Software Foundation; either version
- * 3 of the License, or (at your option) any later version.
- */
-
-#include <common.h>
-#include <command.h>
-#include <asm/mipsregs.h>
-#include <asm/jz4740.h>
-
-DECLARE_GLOBAL_DATA_PTR;
-
-static void gpio_init(void)
-{
- /*
- * Initialize NAND Flash Pins
- */
- __gpio_as_nand();
-
- /*
- * Initialize SDRAM pins
- */
- __gpio_as_sdram_32bit();
-
- /*
- * Initialize LCD pins
- */
- __gpio_as_lcd_8bit();
-
- /*
- * Initialize MSC pins
- */
- __gpio_as_msc();
-
- /*
- * Initialize Other pins
- */
- unsigned int i;
- for (i = 0; i < 7; i++){
- __gpio_as_input(GPIO_KEYIN_BASE + i);
- __gpio_enable_pull(GPIO_KEYIN_BASE + i);
- }
-
- for (i = 0; i < 8; i++) {
- __gpio_as_output(GPIO_KEYOUT_BASE + i);
- __gpio_clear_pin(GPIO_KEYOUT_BASE + i);
- }
-
- /*
- * Initialize UART0 pins, in Ben NanoNote uart0 and keyin8 use the
- * same gpio, init the gpio as uart0 cause a keyboard bug. so for
- * end user we disable the uart0
- */
- if (__gpio_get_pin(GPIO_KEYIN_BASE + 2) == 0){
- /* if pressed [S] */
- printf("[S] pressed, enable UART0\n");
- gd->boot_option = 5;
- __gpio_as_uart0();
- } else {
- printf("[S] not pressed, disable UART0\n");
- __gpio_as_input(GPIO_KEYIN_8);
- __gpio_enable_pull(GPIO_KEYIN_8);
- }
-
- __gpio_as_output(GPIO_AUDIO_POP);
- __gpio_set_pin(GPIO_AUDIO_POP);
-
- __gpio_as_output(GPIO_LCD_CS);
- __gpio_clear_pin(GPIO_LCD_CS);
-
- __gpio_as_output(GPIO_AMP_EN);
- __gpio_clear_pin(GPIO_AMP_EN);
-
- __gpio_as_output(GPIO_SDPW_EN);
- __gpio_disable_pull(GPIO_SDPW_EN);
- __gpio_clear_pin(GPIO_SDPW_EN);
-
- __gpio_as_input(GPIO_SD_DETECT);
- __gpio_disable_pull(GPIO_SD_DETECT);
-
- __gpio_as_input(GPIO_USB_DETECT);
- __gpio_enable_pull(GPIO_USB_DETECT);
-
- if (__gpio_get_pin(GPIO_KEYIN_BASE + 3) == 0) {
- printf("[M] pressed, boot from sd card\n");
- gd->boot_option = 1;
- }
-}
-
-static void cpm_init(void)
-{
- __cpm_stop_ipu();
- __cpm_stop_cim();
- __cpm_stop_i2c();
- __cpm_stop_ssi();
- __cpm_stop_uart1();
- __cpm_stop_sadc();
- __cpm_stop_uhc();
- __cpm_stop_udc();
- __cpm_stop_aic1();
-/* __cpm_stop_aic2();*/
-}
-
-void board_early_init(void)
-{
- gpio_init();
- cpm_init();
-}
-
-/* U-Boot common routines */
-
-int checkboard (void)
-{
-
- printf("Board: Qi LB60 (Ingenic XBurst Jz4740 SoC, Speed %d MHz)\n",
- gd->cpu_clk/1000000);
-
- return 0; /* success */
-}
diff --git a/package/boot/uboot-xburst/files/board/nanonote/u-boot-nand.lds b/package/boot/uboot-xburst/files/board/nanonote/u-boot-nand.lds
deleted file mode 100644
index a15a96ec82..0000000000
--- a/package/boot/uboot-xburst/files/board/nanonote/u-boot-nand.lds
+++ /dev/null
@@ -1,63 +0,0 @@
-/*
- * (C) Copyright 2006
- * Ingenic Semiconductor, <jlwei@ingenic.cn>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of
- * the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- * MA 02111-1307 USA
- */
-
-OUTPUT_FORMAT("elf32-tradlittlemips", "elf32-tradlittlemips", "elf32-tradlittlemips")
-
-OUTPUT_ARCH(mips)
-ENTRY(_start)
-SECTIONS
-{
- . = 0x00000000;
-
- . = ALIGN(4);
- .text :
- {
- *(.text)
- }
-
- . = ALIGN(4);
- .rodata : { *(.rodata) }
-
- . = ALIGN(4);
- .data : { *(.data) }
-
- . = ALIGN(4);
- .sdata : { *(.sdata) }
-
- _gp = ALIGN(16);
-
- __got_start = .;
- .got : { *(.got) }
- __got_end = .;
-
- .sdata : { *(.sdata) }
-
- __u_boot_cmd_start = .;
- .u_boot_cmd : { *(.u_boot_cmd) }
- __u_boot_cmd_end = .;
-
- uboot_end_data = .;
- num_got_entries = (__got_end - __got_start) >> 2;
-
- . = ALIGN(4);
- .sbss : { *(.sbss) }
- .bss : { *(.bss) }
- uboot_end = .;
-}
diff --git a/package/boot/uboot-xburst/files/board/nanonote/u-boot.lds b/package/boot/uboot-xburst/files/board/nanonote/u-boot.lds
deleted file mode 100644
index a15a96ec82..0000000000
--- a/package/boot/uboot-xburst/files/board/nanonote/u-boot.lds
+++ /dev/null
@@ -1,63 +0,0 @@
-/*
- * (C) Copyright 2006
- * Ingenic Semiconductor, <jlwei@ingenic.cn>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of
- * the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- * MA 02111-1307 USA
- */
-
-OUTPUT_FORMAT("elf32-tradlittlemips", "elf32-tradlittlemips", "elf32-tradlittlemips")
-
-OUTPUT_ARCH(mips)
-ENTRY(_start)
-SECTIONS
-{
- . = 0x00000000;
-
- . = ALIGN(4);
- .text :
- {
- *(.text)
- }
-
- . = ALIGN(4);
- .rodata : { *(.rodata) }
-
- . = ALIGN(4);
- .data : { *(.data) }
-
- . = ALIGN(4);
- .sdata : { *(.sdata) }
-
- _gp = ALIGN(16);
-
- __got_start = .;
- .got : { *(.got) }
- __got_end = .;
-
- .sdata : { *(.sdata) }
-
- __u_boot_cmd_start = .;
- .u_boot_cmd : { *(.u_boot_cmd) }
- __u_boot_cmd_end = .;
-
- uboot_end_data = .;
- num_got_entries = (__got_end - __got_start) >> 2;
-
- . = ALIGN(4);
- .sbss : { *(.sbss) }
- .bss : { *(.bss) }
- uboot_end = .;
-}