aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-05-20 21:01:18 +0000
committerLuka Perkov <luka@openwrt.org>2014-05-20 21:01:18 +0000
commitc8b254e5ff25207026c5ba94b2e8fddf0e2db9d4 (patch)
treeaa99085de6815b93174207f47b77b2ffac713497 /package/boot/uboot-imx6/Makefile
parent0c5c07595f820ba646760101a6b0be04bd5169e6 (diff)
downloadmaster-187ad058-c8b254e5ff25207026c5ba94b2e8fddf0e2db9d4.tar.gz
master-187ad058-c8b254e5ff25207026c5ba94b2e8fddf0e2db9d4.tar.bz2
master-187ad058-c8b254e5ff25207026c5ba94b2e8fddf0e2db9d4.zip
[package] uboot-imx6: update to 2014.04
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40805 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 0c989f3cfb..7074da9f0d 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2014.04
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -98,11 +100,13 @@ UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin
endif
define Build/Configure
- $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+ $(UBOOT_CONFIG)_config
endef
define Build/Compile
- $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+ CROSS_COMPILE=$(TARGET_CROSS)
endef
define Package/uboot/install/default