aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-05-29 01:27:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-05-29 01:27:30 +0000
commitb8b35e19baf20e7859c8a2b165d8b8cffdd2f14e (patch)
tree00eac7f5488d11d38f9eb24f5b1f59f55ef91650 /package/boot/uboot-imx6/Makefile
parent719e33cf007153b5874cb6a9f37cf0947f64888d (diff)
downloadmaster-187ad058-b8b35e19baf20e7859c8a2b165d8b8cffdd2f14e.tar.gz
master-187ad058-b8b35e19baf20e7859c8a2b165d8b8cffdd2f14e.tar.bz2
master-187ad058-b8b35e19baf20e7859c8a2b165d8b8cffdd2f14e.zip
[package] uboot-imx6: add new package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile93
1 files changed, 93 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
new file mode 100644
index 0000000000..16465c78e2
--- /dev/null
+++ b/package/boot/uboot-imx6/Makefile
@@ -0,0 +1,93 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2013.04
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+ TITLE:=
+ CONFIG:=
+ IMAGE:=
+endef
+
+define uboot/wandboard_solo
+ TITLE:=U-Boot for the Wandboard Solo
+endef
+
+define uboot/wandboard_dl
+ TITLE:=U-Boot for the Wandboard Dual Lite
+endef
+
+UBOOTS := \
+ wandboard_solo \
+ wandboard_dl
+
+define Package/uboot/template
+define Package/uboot-imx6-$(1)
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ DEPENDS:=@TARGET_imx6
+ TITLE:=$(2)
+ URL:=http://www.denx.de/wiki/U-Boot
+ VARIANT:=$(1)
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+endef
+
+define BuildUBootPackage
+ $(eval $(uboot/Default))
+ $(eval $(uboot/$(1)))
+ $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+ifdef BUILD_VARIANT
+$(eval $(call uboot/$(BUILD_VARIANT)))
+UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+endif
+
+define Build/Configure
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(UBOOT_CONFIG)_config
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CROSS_COMPILE=$(TARGET_CROSS)
+endef
+
+define Package/uboot/install/default
+ $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+ $(CP) \
+ $(PKG_BUILD_DIR)/u-boot.imx \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.imx
+endef
+
+define Package/uboot/install/template
+define Package/uboot-imx6-$(1)/install
+ $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(call BuildUBootPackage,$(u))) \
+ $(eval $(call BuildPackage,uboot-imx6-$(u))) \
+)