aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-04-11 16:04:31 +0000
committerLuka Perkov <luka@openwrt.org>2013-04-11 16:04:31 +0000
commit9b2655fa707672c4f26d95f6856253ff43b61d17 (patch)
tree9de1e96047b2e89fb9c985e237c90901d195523d /package/boot/uboot-envtools/Makefile
parentce4da1634d181c883b3d7c099d034390147e918c (diff)
downloadmaster-187ad058-9b2655fa707672c4f26d95f6856253ff43b61d17.tar.gz
master-187ad058-9b2655fa707672c4f26d95f6856253ff43b61d17.tar.bz2
master-187ad058-9b2655fa707672c4f26d95f6856253ff43b61d17.zip
This adds Gateworks Laguna family board support. Note that some Laguna
boards have SPI flash and others have NOR flash, thus the size/erasesize are detected dynamically. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 55aaf885f1..ded9678be9 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_TARGET_ramips),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_cns3xxx),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/uboot-envtools
+endif
endef
$(eval $(call BuildPackage,uboot-envtools))