aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-29 12:38:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-29 12:38:35 +0000
commit709b91a2bf362279d1dc25b927777b980fe7a22d (patch)
tree42440936fd261a894b7de983d01317922d845641 /package/boot/uboot-envtools/Makefile
parent9bbab1b2bb9ba042d10ba6525a740e44ae17da69 (diff)
downloadmaster-187ad058-709b91a2bf362279d1dc25b927777b980fe7a22d.tar.gz
master-187ad058-709b91a2bf362279d1dc25b927777b980fe7a22d.tar.bz2
master-187ad058-709b91a2bf362279d1dc25b927777b980fe7a22d.zip
[uboot-envtools]: add mvebu support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41380 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-envtools/Makefile')
-rw-r--r--package/boot/uboot-envtools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 301a0e432a..c6f1fbaff6 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2014.04
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@@ -86,6 +86,10 @@ ifneq ($(CONFIG_TARGET_lantiq),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_DATA) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
endif
+ifneq ($(CONFIG_TARGET_mvebu),)
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/mvebu $(1)/etc/uci-defaults/30_uboot-envtools
+endif
ifneq ($(CONFIG_TARGET_mxs),)
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/mxs $(1)/etc/uci-defaults/30_uboot-envtools