aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kobs-ng/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-03 23:22:16 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-03 23:22:16 +0000
commit4b85b2d0bccf21c32f516b7420cabd11f8e90ab8 (patch)
tree3f9977e420526ac1934d2eef3767f6d12b819179 /package/boot/kobs-ng/Makefile
parent2099ed326c2a827aee26ab749e3164e4b21ea825 (diff)
downloadmaster-187ad058-4b85b2d0bccf21c32f516b7420cabd11f8e90ab8.tar.gz
master-187ad058-4b85b2d0bccf21c32f516b7420cabd11f8e90ab8.tar.bz2
master-187ad058-4b85b2d0bccf21c32f516b7420cabd11f8e90ab8.zip
[package] kobs-ng: add new package
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37894 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/kobs-ng/Makefile')
-rw-r--r--package/boot/kobs-ng/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/boot/kobs-ng/Makefile b/package/boot/kobs-ng/Makefile
new file mode 100644
index 0000000000..1554e6835d
--- /dev/null
+++ b/package/boot/kobs-ng/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kobs-ng
+PKG_VERSION:=3.0.35-4.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/k/kobs-ng/kobs-ng-$(PKG_VERSION)/
+PKG_MD5SUM:=26104c577f59a6b81782a5bd16aadd82
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kobs-ng
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Application for writing bootstreams to NAND flash
+ DEPENDS:=@TARGET_imx6
+endef
+
+define Package/kobs-ng/description
+ The kobs-ng application writes a bootstream to NAND flash with the proper
+ FCB/DBBT headers and replicated streams.
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "const char* git_sha = \"$(PKG_VERSION)\";" > $(PKG_BUILD_DIR)/autoversion.h
+endef
+
+define Package/kobs-ng/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/kobs-ng $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,kobs-ng))