aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:16 +0000
commit6a1c210ea78738d971b8fd9b99fa91bb177297bd (patch)
tree78b575ee74f83daf1a27607add4f2f895d29d17d /package/boot/kexec-tools/Makefile
parent4dc34e5cc4df6c1bb2974d0903c8053a0cb87598 (diff)
downloadmaster-187ad058-6a1c210ea78738d971b8fd9b99fa91bb177297bd.tar.gz
master-187ad058-6a1c210ea78738d971b8fd9b99fa91bb177297bd.tar.bz2
master-187ad058-6a1c210ea78738d971b8fd9b99fa91bb177297bd.zip
kexec-tools: reduce size
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37072 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/kexec-tools/Makefile')
-rw-r--r--package/boot/kexec-tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 541dca275a..40ba9eb525 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -56,6 +56,9 @@ CONFIGURE_ARGS = \
--sysconfdir=/etc \
$(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"