aboutsummaryrefslogtreecommitdiffstats
path: root/package/block-mount
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2011-04-05 12:12:57 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2011-04-05 12:12:57 +0000
commita353e17d8fe3be22490adcea13de3cd859039f64 (patch)
tree21751ae837431af618c34068ef259d79dc1e62aa /package/block-mount
parent3f7ddd92ae3c55de27e4d38cdba6714d35fa3d3c (diff)
downloadmaster-187ad058-a353e17d8fe3be22490adcea13de3cd859039f64.tar.gz
master-187ad058-a353e17d8fe3be22490adcea13de3cd859039f64.tar.bz2
master-187ad058-a353e17d8fe3be22490adcea13de3cd859039f64.zip
[package] block-mount base-files: Added additional check to pi_include to ensure that a directory used with pi_include actually contains files matching the souring pattern because if not the shell dies due to an empty string in for statement. Added /lib/functions/fsck as an empty dir to block-mount. This combination fixes a warning which generates a lot of bug reports, without panicking the kernel like the last attempt.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26479 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/block-mount')
-rw-r--r--package/block-mount/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index d2313f77f4..c2c9d33f13 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=block-mount
PKG_VERSION:=0.2.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
include $(INCLUDE_DIR)/package.mk
@@ -50,7 +50,7 @@ define Package/block-mount/install
$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
- $(INSTALL_DIR) $(1)/lib/functions
+ $(INSTALL_DIR) $(1)/lib/functions/fsck
$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/block.sh $(1)/lib/functions/