aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-16 02:42:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-16 02:42:24 +0000
commita903f8ca05ceabf49c55dd4f4095739132e6bfaf (patch)
tree01ab16d90262cde3de80ad277f60b1dce3b38683 /package/base-files
parentafa1c55fbd81c7c3e627c620dd52422d64be378d (diff)
downloadmaster-187ad058-a903f8ca05ceabf49c55dd4f4095739132e6bfaf.tar.gz
master-187ad058-a903f8ca05ceabf49c55dd4f4095739132e6bfaf.tar.bz2
master-187ad058-a903f8ca05ceabf49c55dd4f4095739132e6bfaf.zip
base-files: librt should depend on libpthread, not the other way around
In uClibc 0.9.32 as well as recent versions of glibc and eglibc, librt depends on libpthread. Signed-off-by: Mark Mentovai <mark@moxienet.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25548 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 82bf51a2bd..3ccd2c7f4b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -196,7 +196,6 @@ endef
define Package/libpthread
$(call Package/libc/Default)
TITLE:=POSIX thread library
- DEPENDS:= +librt
endef
define Package/libpthread/config
@@ -223,6 +222,7 @@ endef
define Package/librt
$(call Package/libc/Default)
TITLE:=POSIX.1b RealTime extension library
+ DEPENDS:=+libpthread
endef
define Package/librt/config