aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-18 10:32:38 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-18 10:32:38 +0000
commit7255912a1c8c4e3cf970d485a6f9753cfd8ec7c3 (patch)
tree67f48f2fe9043485226cd56866bbd2514c9dee6f /package/base-files
parent2785f72a9f2e6458e30b5f65d8e42cb11e6541fe (diff)
downloadmaster-187ad058-7255912a1c8c4e3cf970d485a6f9753cfd8ec7c3.tar.gz
master-187ad058-7255912a1c8c4e3cf970d485a6f9753cfd8ec7c3.tar.bz2
master-187ad058-7255912a1c8c4e3cf970d485a6f9753cfd8ec7c3.zip
[package] base-files: check for libpthread_so.a instead of libc_so.a (some gcc/libc combinations don't provide a libpthread_so.a matching libc_so.a)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18810 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5957f1406b..67837120b6 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -434,7 +434,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endef
define Package/libpthread/install_lib
- $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libpthread_so.a $(1)/lib/libpthread_pic.a)
+ $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libpthread_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libpthread_so.a $(1)/lib/libpthread_pic.a)
endef
define Package/librt/install