aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-23 14:44:31 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-23 14:44:31 +0000
commit5daf93b096cc49b1ac91b9b9519af010f961030c (patch)
treedfbbe742ef81710be6f0741ed65218e5154139d1 /package/base-files/Makefile
parentf5cb31b10d81453a0ffe4b02b39a53ab144326a5 (diff)
downloadmaster-187ad058-5daf93b096cc49b1ac91b9b9519af010f961030c.tar.gz
master-187ad058-5daf93b096cc49b1ac91b9b9519af010f961030c.tar.bz2
master-187ad058-5daf93b096cc49b1ac91b9b9519af010f961030c.zip
base-files: allow timezone to be overriden by zonename (proper zoneinfo support)
Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47980 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1367fa9291..bf32f6306a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=164
+PKG_RELEASE:=165
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=usign/host
@@ -161,7 +161,7 @@ define Package/base-files/install
rm -f $(1)/var
$(LN) /tmp $(1)/var
mkdir -p $(1)/etc
- $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+ $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ /tmp/localtime $(1)/etc/
chmod 0600 $(1)/etc/shadow
chmod 1777 $(1)/tmp