aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:19 +0000
committerJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:19 +0000
commit47d1577ffb1727e63a27c50a29d65cbea5625935 (patch)
tree4aeff8c4041964f40a41b510ee951adf81dffe17 /package/base-files/Makefile
parentbbb2cf0b18a152a867512ed72126d3560f581f9c (diff)
downloadmaster-187ad058-47d1577ffb1727e63a27c50a29d65cbea5625935.tar.gz
master-187ad058-47d1577ffb1727e63a27c50a29d65cbea5625935.tar.bz2
master-187ad058-47d1577ffb1727e63a27c50a29d65cbea5625935.zip
[base-files] make basefiles aware of procd
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36003 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b763658549..90c280645d 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -15,6 +15,7 @@ PKG_RELEASE:=134
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
include $(INCLUDE_DIR)/package.mk
@@ -55,6 +56,18 @@ define Package/base-files/description
This package contains a base filesystem and system scripts for OpenWrt.
endef
+define Package/base-files/config
+config PROCD_INIT
+ bool "Use procd as the init process"
+ default n
+endef
+
+ifeq ($(CONFIG_PROCD_INIT),)
+define InstallOldFiles
+ $(CP) ./files.old/* $(1)/
+endef
+endif
+
ifneq ($(CONFIG_PREINITOPT),)
define ImageConfigOptions
mkdir -p $(1)/lib/preinit
@@ -87,6 +100,7 @@ define Package/base-files/install
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
fi
+ $(call InstallOldFiles,$(1))
if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
fi