aboutsummaryrefslogtreecommitdiffstats
path: root/package/arptables/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-07-30 17:53:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-07-30 17:53:04 +0000
commit19f4a7fb41e20c4bd9f61ca039471da25103e627 (patch)
tree7978245c8b743181303b69165f31bcef0384de5d /package/arptables/Makefile
parentba51da6a711908fd985b367e213910baed2676a7 (diff)
downloadmaster-187ad058-19f4a7fb41e20c4bd9f61ca039471da25103e627.tar.gz
master-187ad058-19f4a7fb41e20c4bd9f61ca039471da25103e627.tar.bz2
master-187ad058-19f4a7fb41e20c4bd9f61ca039471da25103e627.zip
Port arptables to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4340 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/arptables/Makefile')
-rw-r--r--package/arptables/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/arptables/Makefile b/package/arptables/Makefile
new file mode 100644
index 0000000000..b4bfe18a73
--- /dev/null
+++ b/package/arptables/Makefile
@@ -0,0 +1,46 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=arptables
+PKG_VERSION:=0.0.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=1672244603c8979577aa4738be35a759
+
+PKG_SOURCE_URL:=@SF/ebtables
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/arptables
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=ARP firewalling software
+ DESCRIPTION:=ARP firewalling software
+ URL:=http://ebtables.sourceforge.net
+endef
+
+define Build/Compile
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+ COPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL_DIR="./include/linux"
+endef
+
+define Package/arptables/install
+ install -m0755 -d $(1)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,arptables))