aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-13 06:25:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-13 06:25:54 +0000
commitd42667f87b64429b0919f542996ca5132d09e8b6 (patch)
tree0f0417bb685fd2df11ad192254a394cd7401e162 /include
parentb5e0831f1e38330b2c18ec2634d447200e04414f (diff)
downloadmaster-187ad058-d42667f87b64429b0919f542996ca5132d09e8b6.tar.gz
master-187ad058-d42667f87b64429b0919f542996ca5132d09e8b6.tar.bz2
master-187ad058-d42667f87b64429b0919f542996ca5132d09e8b6.zip
clean up openwrt version handling, use a separate script that is executed at the beginning of the build process, fix revision checking with git
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/toplevel.mk17
1 files changed, 6 insertions, 11 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 040ff51249..63325aa018 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -7,20 +7,15 @@
#
RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
SHELL:=/usr/bin/env bash
-OPENWRTVERSION:=$(RELEASE)
PREP_MK= OPENWRT_BUILD= QUIET=0
+
include $(TOPDIR)/include/verbose.mk
-ifneq ($(VERSION),)
- OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
- REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
- ifneq ($(REV),)
- OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
- endif
-endif
+
+REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
+OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
+export RELEASE
+export REVISION
export OPENWRTVERSION
export IS_TTY=$(shell tty -s && echo 1 || echo 0)