aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
commitbb6c4aade1c3174895429f168d4eac7a67d312cd (patch)
treeeb4212ed9fc412f6018213aec05fae3059ed20bf /include
parent499485004b52b5960c950922fb1dedcedd0923fa (diff)
downloadmaster-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.gz
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.bz2
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.zip
add $(STAGING_DIR) as argument to the InstallDev template and update packages accordingly - this way we can reuse InstallDev to automatically generate UninstallDev or create -dev packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9052 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 9090455658..2b93972f24 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -64,7 +64,7 @@ define Build/DefaultTargets
$(STAMP_BUILT): $(STAMP_CONFIGURED)
$(Build/Compile)
- $(Build/InstallDev)
+ $(call Build/InstallDev,$(STAGING_DIR))
touch $$@
ifdef Build/InstallDev
@@ -142,7 +142,7 @@ configure: $(STAMP_CONFIGURED)
compile:
install:
clean: FORCE
- $(Build/UninstallDev)
+ $(call Build/UninstallDev,$(STAGING_DIR))
$(Build/Clean)
@rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
@rm -rf $(PKG_BUILD_DIR)