aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:45 +0000
commit815dc7a50b65c2cd32b7f4d0bdc44be6b284b711 (patch)
tree5d08a019b4cf28ebc8535c315bb9aec2a825f3c0 /include
parent5c8dbe162d349de8f3fc45a475a49dfdeef40e36 (diff)
downloadmaster-187ad058-815dc7a50b65c2cd32b7f4d0bdc44be6b284b711.tar.gz
master-187ad058-815dc7a50b65c2cd32b7f4d0bdc44be6b284b711.tar.bz2
master-187ad058-815dc7a50b65c2cd32b7f4d0bdc44be6b284b711.zip
[buildroot] image.mk: don't squash file permissions in JFFS2 images
Currently we call mkfs.jffs2 --squash, which will change both file permissions and owners. If we have some file with suid bits, it will clear these bits. Thus it's enough to just squash file owners, by replacing that argument to --squash-uids. Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34397 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 1977fc84c0..10850a6327 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -18,9 +18,9 @@ KDIR=$(KERNEL_BUILD_DIR)
IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
ifneq ($(CONFIG_BIG_ENDIAN),)
- JFFS2OPTS := --pad --big-endian --squash -v
+ JFFS2OPTS := --pad --big-endian --squash-uids -v
else
- JFFS2OPTS := --pad --little-endian --squash -v
+ JFFS2OPTS := --pad --little-endian --squash-uids -v
endif
ifeq ($(CONFIG_JFFS2_RTIME),y)