aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-13 03:35:14 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-13 03:35:14 +0000
commit75f47798f97b184293a96213513b0698c1318b7c (patch)
treeaf04faae5a8515f74b76b34a9d5445fdeacb9b09 /include
parent96a1645d52f799b713c5f9034cd137d00cf990a2 (diff)
downloadmaster-187ad058-75f47798f97b184293a96213513b0698c1318b7c.tar.gz
master-187ad058-75f47798f97b184293a96213513b0698c1318b7c.tar.bz2
master-187ad058-75f47798f97b184293a96213513b0698c1318b7c.zip
image: introduce MkuImageARM function
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38380 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index aa3bf27de0..67cfa4b677 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -82,6 +82,11 @@ else
endef
endif
+define Image/BuildKernel/MkuImageARM
+ mkimage -A arm -O linux -T kernel -a $(1) -C none -e $(1) \
+ -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(2) $(3)
+endef
+
define Image/mkfs/jffs2/sub
# FIXME: removing this line will cause strange behaviour in the foreach loop below
$(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) --pad -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'