aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-14 12:49:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-14 12:49:30 +0000
commit4a7f3ec126705c29362e65ade4bc52a6de9ba0a6 (patch)
tree01c66508adcec7776d9fcf96638c0463c73a21d4 /include
parente87605ee996b37931a96a790bcd07d2b8f20401f (diff)
downloadmaster-187ad058-4a7f3ec126705c29362e65ade4bc52a6de9ba0a6.tar.gz
master-187ad058-4a7f3ec126705c29362e65ade4bc52a6de9ba0a6.tar.bz2
master-187ad058-4a7f3ec126705c29362e65ade4bc52a6de9ba0a6.zip
build: replace the deprecated find argument -perm +0100 with /0100 (#19480)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45434 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 6e0456f42a..31689c7e6b 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -244,8 +244,8 @@ endef
define Image/mkfs/prepare/default
# Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
- - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
- - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
+ - $(FIND) $(TARGET_DIR) -type f -not -perm /0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
+ - $(FIND) $(TARGET_DIR) -type f -perm /0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
- $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
$(INSTALL_DIR) $(TARGET_DIR)/tmp $(TARGET_DIR)/overlay
chmod 1777 $(TARGET_DIR)/tmp