aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-30 21:42:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-30 21:42:57 +0000
commit24524856f9ecd2cf3c71f39ab4c354a9a2ef100d (patch)
treeb5a2a441bce7081b8da7f6b95eee40ae51fb6bdb /include
parenta2a0717b73b404f686b7db3ffcd4dfec2e7d1aa3 (diff)
downloadmaster-187ad058-24524856f9ecd2cf3c71f39ab4c354a9a2ef100d.tar.gz
master-187ad058-24524856f9ecd2cf3c71f39ab4c354a9a2ef100d.tar.bz2
master-187ad058-24524856f9ecd2cf3c71f39ab4c354a9a2ef100d.zip
fix kernel config feature autodetection
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7811 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index e6fc3325e6..e0fda0ddf9 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -29,7 +29,6 @@ else
KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
PLATFORM_DIR := $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL)
PATCH_DIR := ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
- GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
KERNEL_BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
LINUX_DIR := $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
@@ -47,8 +46,8 @@ else
http://www.de.kernel.org/pub/linux/kernel/v$(KERNEL)$(TESTING)
PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
endif
+GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
define KernelPackage/Defaults