aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 23:13:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 23:13:52 +0000
commite8503a6ff092d0d7af9b4ec84de93ef7ed0adcc2 (patch)
tree401735036a11a5144aa9b6c723e8c9b4b79bc196 /include/target.mk
parent65355dcead52a377604ccd5667d710ac9cd2dd5f (diff)
downloadmaster-187ad058-e8503a6ff092d0d7af9b4ec84de93ef7ed0adcc2.tar.gz
master-187ad058-e8503a6ff092d0d7af9b4ec84de93ef7ed0adcc2.tar.bz2
master-187ad058-e8503a6ff092d0d7af9b4ec84de93ef7ed0adcc2.zip
set the PROFILE variable in target.mk appropriately
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6470 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index bd3ceb955b..d0f7b9bc2b 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -7,6 +7,12 @@
include $(TMP_DIR)/.target.mk
+define AddProfile
+ ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
+ PROFILE=$(1)
+ endif
+endef
+
ifeq ($(IB),1)
$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
$(CP) $< $@