aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit499485004b52b5960c950922fb1dedcedd0923fa (patch)
tree78a221d6379016a74f33e2257e609a7194db7f27 /include/target.mk
parentd2c8e2185055230a43bafaa28017dc11ee40d927 (diff)
downloadmaster-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.tar.gz
master-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.tar.bz2
master-187ad058-499485004b52b5960c950922fb1dedcedd0923fa.zip
some minor fixes, cleanups, package build abstraction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index c8eb76c254..1590b91091 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -75,9 +75,11 @@ define Profile
endif
endef
--include $(PLATFORM_DIR)/profiles/*.mk
-ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
- -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
+ -include $(PLATFORM_DIR)/profiles/*.mk
+ ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ endif
endif
$(eval $(call shexport,Target/Description))