aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 18:17:40 +0000
commit3249931be4d02d83a1fb9225d4355e1fa2509da8 (patch)
treeeee75efb521525000f257533dee3114ccfbdcc2a /include/target.mk
parentd60f2546168f82bff620d2909936e27865d91273 (diff)
downloadmaster-187ad058-3249931be4d02d83a1fb9225d4355e1fa2509da8.tar.gz
master-187ad058-3249931be4d02d83a1fb9225d4355e1fa2509da8.tar.bz2
master-187ad058-3249931be4d02d83a1fb9225d4355e1fa2509da8.zip
commit profile support for base-files... patches still need to be done
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6465 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index bd3ceb955b..6a136a1bee 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -5,6 +5,21 @@
# See /LICENSE for more information.
#
+define AddProfile
+ $(eval $(call Profile/Default))
+ $(eval $(call Profile/$(1)))
+ ifneq ($(ID),)
+ PROFILE:=$(ID)
+ $(ID)_NAME:=$(NAME)
+ $(ID)_PACKAGES:=$(PACKAGES)
+ ifneq ($(KCONFIG),)
+ PROFILE_LIST += \
+ echo '$(ID):'; [ -z '$(NAME)' ] || echo ' $(NAME)'; echo ' Packages: $(PACKAGES)';
+ endif
+ endif
+endef
+
+
include $(TMP_DIR)/.target.mk
ifeq ($(IB),1)