aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 19:52:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 19:52:54 +0000
commite9531fed6e1b31a8dd287f203d36518b8b6fe2c7 (patch)
tree4ae0f03f14862f6faefe3a48df4278f66f5335f3 /include/quilt.mk
parentae51b57add201ec5792de1e09f12d68f04334c6f (diff)
downloadmaster-187ad058-e9531fed6e1b31a8dd287f203d36518b8b6fe2c7.tar.gz
master-187ad058-e9531fed6e1b31a8dd287f203d36518b8b6fe2c7.tar.bz2
master-187ad058-e9531fed6e1b31a8dd287f203d36518b8b6fe2c7.zip
more fixes for the patching stuff (was testing it on the wrong target)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7483 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index e77e0db772..e8c3b90a68 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -49,8 +49,9 @@ define Kernel/Patch/Default
if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
)
$(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
- if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+ if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
)
+ $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
$(STAMP_PATCHED): $(STAMP_PREPARED)