aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-25 19:45:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-25 19:45:22 +0000
commitffeaf39fd456d83022f31c64c931aa54b9269668 (patch)
tree25bc345f15c45217c90f235cd982e57e65091d22 /include/package.mk
parent815c894068009f41486bcdb2accc8faf3bc26ff1 (diff)
downloadmaster-187ad058-ffeaf39fd456d83022f31c64c931aa54b9269668.tar.gz
master-187ad058-ffeaf39fd456d83022f31c64c931aa54b9269668.tar.bz2
master-187ad058-ffeaf39fd456d83022f31c64c931aa54b9269668.zip
fix pesky kmod-* ipkg install bug
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5639 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 4e67e73246..69606464ae 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -208,11 +208,11 @@ define BuildPackage
echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
( \
- DEPENDS=; \
+ DEPENDS='$(EXTRA_DEPENDS)'; \
for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
done; \
- echo "Depends: $(EXTRA_DEPENDS) $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+ echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
)
echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control