aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 23:54:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 23:54:05 +0000
commiteaf40953270e790fe3ba4b7bc8dd19c308efed90 (patch)
tree4fe3a2a7810df41110ccd595f3e0f672c3fd65b9 /include/package.mk
parentc99fbd93f5e977a9c39d21e46b63a4adb730d733 (diff)
downloadmaster-187ad058-eaf40953270e790fe3ba4b7bc8dd19c308efed90.tar.gz
master-187ad058-eaf40953270e790fe3ba4b7bc8dd19c308efed90.tar.bz2
master-187ad058-eaf40953270e790fe3ba4b7bc8dd19c308efed90.zip
fix the host vs native stampfile dependencies to improve quilt support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14629 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 2b28b648b2..e33814e77d 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -69,7 +69,7 @@ define Build/DefaultTargets
$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
$(call Build/Autoclean)
- $(STAMP_PREPARED): $(HOST_STAMP_INSTALLED)
+ $(STAMP_PREPARED):
@-rm -rf $(PKG_BUILD_DIR)
@mkdir -p $(PKG_BUILD_DIR)
$(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
@@ -77,7 +77,7 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
touch $$@
- $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+ $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(HOST_STAMP_INSTALLED)
$(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
$(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))