aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:58 +0000
commit8a710d2900cdedadf91c5e7d96cf46cef3b7c6ad (patch)
tree83016bf459e9c793e1e4112bdb1f5ea14f35372d /include/package.mk
parent5434e7d89f96432832664361355c0854ecda6f22 (diff)
downloadmaster-187ad058-8a710d2900cdedadf91c5e7d96cf46cef3b7c6ad.tar.gz
master-187ad058-8a710d2900cdedadf91c5e7d96cf46cef3b7c6ad.tar.bz2
master-187ad058-8a710d2900cdedadf91c5e7d96cf46cef3b7c6ad.zip
add an extra build step Build/Install which allows you to run a make install target after the post-compile hooks have run - will be necessary for some libtool dependent stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12452 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 8819a11564..e0f8c719f4 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -81,6 +81,8 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
$(Build/Compile)
$(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))
+ $(Build/Install)
+ $(foreach hook,$(Hooks/Install/Post),$(call $(hook))$(sep))
touch $$@
$(STAMP_INSTALLED): $(STAMP_BUILT)