aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-17 11:17:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-17 11:17:26 +0000
commit1281f1c74c1ef02cdd8c75320d9b20384234e9bd (patch)
tree4cd1192966486c23577d2fc948b6ec7546d03add /include/package.mk
parentceab097ad9062383b9f46bf370e830f75e6f9ada (diff)
downloadmaster-187ad058-1281f1c74c1ef02cdd8c75320d9b20384234e9bd.tar.gz
master-187ad058-1281f1c74c1ef02cdd8c75320d9b20384234e9bd.tar.bz2
master-187ad058-1281f1c74c1ef02cdd8c75320d9b20384234e9bd.zip
build: ensure that package/host-build build system code does not run in parallel, fixes rare spurious parallel build failures
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33445 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index e93aebf67d..3ec5ffdadd 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -248,6 +248,8 @@ Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
Build/Dist=$(call Build/Dist/Default,)
Build/DistCheck=$(call Build/DistCheck/Default,)
+.NOTPARALLEL:
+
$(PACKAGE_DIR):
mkdir -p $@