aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
commit0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd (patch)
tree1d1c315a271b098592c1dd1756b91a5117d85c1c /include/package.mk
parent8ef94e67c30efa29aa74956a981a9aee4a75dac9 (diff)
downloadmaster-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.gz
master-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.bz2
master-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.zip
build: add a config option for choosing the prefered standard c++ library and add uclibc++.mk to make this easy to handle in packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index e955c207ae..abffa0c64c 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -5,6 +5,8 @@
# See /LICENSE for more information.
#
+__package_mk:=1
+
all: $(if $(DUMP),dumpinfo,compile)
PKG_BUILD_DIR ?= $(BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))