aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-07-15 19:29:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-07-15 19:29:43 +0000
commitf1a3abbd19e2831dc55c3a78939c7ba88e3783ae (patch)
tree20a590ef5174fa08332cef8933613318e9f0d4be /include/package-ipkg.mk
parent35fed0980c47ab77d72887ae113a9a45eefba005 (diff)
downloadmaster-187ad058-f1a3abbd19e2831dc55c3a78939c7ba88e3783ae.tar.gz
master-187ad058-f1a3abbd19e2831dc55c3a78939c7ba88e3783ae.tar.bz2
master-187ad058-f1a3abbd19e2831dc55c3a78939c7ba88e3783ae.zip
[include] package-ipkg.mk: flag packages as "ok" after install
By flagging compile-time-installed packages as "ok", they can be differentiated from runtime-installed packages on the target later on. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 0ce2055061..14520cfd95 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -191,7 +191,7 @@ ifeq ($(DUMP),)
$$(INFO_$(1)): $$(IPKG_$(1))
@[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
$(OPKG) install $$(IPKG_$(1))
- $(if $(filter-out essential,$(PKG_FLAGS)),for flag in $(filter-out essential,$(PKG_FLAGS)); do $(OPKG) flag $$$$flag $(1); done)
+ $(if $(filter-out essential,$(PKG_FLAGS)),for flag in $(filter-out essential,$(PKG_FLAGS)); do $(OPKG) flag $$$$flag $(1); done,$(OPKG) flag ok $(1))
$(1)-clean:
rm -f $(PACKAGE_DIR)/$(1)_*