aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-17 10:14:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-17 10:14:25 +0000
commit76260922ffe137227bdc3bb3197d4c03ea9301d7 (patch)
treefe7fde0742e733a2ba66d1a0c6266e7ff70f54c8 /include/package-ipkg.mk
parent345eed8e265adaa36d4e8487be01f6d9d34864b6 (diff)
downloadmaster-187ad058-76260922ffe137227bdc3bb3197d4c03ea9301d7.tar.gz
master-187ad058-76260922ffe137227bdc3bb3197d4c03ea9301d7.tar.bz2
master-187ad058-76260922ffe137227bdc3bb3197d4c03ea9301d7.zip
[package] ensure CONTROL directory is created (#5683)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17293 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 4af052c37a..72d6d596b7 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -90,6 +90,7 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(STAMP_BUILT) $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
+ mkdir -p $$(IDIR_$(1))/CONTROL
mkdir -p $(PACKAGE_DIR)
-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
$(RSTRIP) $$(IDIR_$(1))