aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 02:10:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 02:10:32 +0000
commit6f8262a64aabf11f6ee20792009d3538acc47fe9 (patch)
treed0f96ca69325f5732889e17fd26173dc478aaa16 /include/package-ipkg.mk
parent8249039087290abbf0d7afb449410d2695c2bb15 (diff)
downloadmaster-187ad058-6f8262a64aabf11f6ee20792009d3538acc47fe9.tar.gz
master-187ad058-6f8262a64aabf11f6ee20792009d3538acc47fe9.tar.bz2
master-187ad058-6f8262a64aabf11f6ee20792009d3538acc47fe9.zip
build: move the SH_FUNC eval to the beginning of the opkg control file build command chain, not in front of every single command
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26432 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 9cccff261a..33b9ef8353 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -30,7 +30,7 @@ IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
define BuildIPKGVariable
ifdef Package/$(1)/$(2)
$(call shexport,Package/$(1)/$(2))
- $(1)_COMMANDS += $(SH_FUNC) var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+ $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
endif
endef
@@ -113,7 +113,7 @@ ifeq ($(DUMP),)
echo -n "Description: "; $(SH_FUNC) getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
) > $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
- (cd $$(IDIR_$(1))/CONTROL; \
+ $(SH_FUNC) (cd $$(IDIR_$(1))/CONTROL; \
$($(1)_COMMANDS) \
)