aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-24 12:05:30 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-24 12:05:30 +0000
commit4a3e32d0006ca3e8b7fad8653681733a2ea1dcc3 (patch)
treeb861eef94891d61e87cf25b6ab49f10834b18711 /include/package-ipkg.mk
parent6fdd166a4e47dd248a06c84bc12dc2f50e28ba82 (diff)
downloadmaster-187ad058-4a3e32d0006ca3e8b7fad8653681733a2ea1dcc3.tar.gz
master-187ad058-4a3e32d0006ca3e8b7fad8653681733a2ea1dcc3.tar.bz2
master-187ad058-4a3e32d0006ca3e8b7fad8653681733a2ea1dcc3.zip
combine the 3 find in a single one
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8477 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 597f5f87c3..36f030375d 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -63,9 +63,7 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS | $(XARGS) rm -rf
- -find $$(IDIR_$(1)) -name .svn | $(XARGS) rm -rf
- -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
+ -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false