aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-02 03:21:33 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-02 03:21:33 +0000
commit30b73856340c842cc12f7fc8d6409c0c7f514e90 (patch)
tree278ced18c5d165fac2ef2979df02ba589bb0b03a /include/package-ipkg.mk
parent36dc978a0e888bf45ad2066378b5b49b0da4ea90 (diff)
downloadmaster-187ad058-30b73856340c842cc12f7fc8d6409c0c7f514e90.tar.gz
master-187ad058-30b73856340c842cc12f7fc8d6409c0c7f514e90.tar.bz2
master-187ad058-30b73856340c842cc12f7fc8d6409c0c7f514e90.zip
[include] add support for flagging packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23172 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index dbf8721977..edee6a4c55 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -117,6 +117,7 @@ ifeq ($(DUMP),)
$$(INFO_$(1)): $$(IPKG_$(1))
@[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
$(OPKG) install $$(IPKG_$(1))
+ $(if $(PKGFLAGS),for flag in $(PKGFLAGS); do $(OPKG) flag $$$$flag $(1); done)
$(1)-clean:
rm -f $(PACKAGE_DIR)/$(1)_*