aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-21 21:48:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-21 21:48:18 +0000
commitfd0fbff63dbbb7fb2e41a2612922ccd65006517f (patch)
tree4c7d1a04a0c77fb187810b282336f29bec5c6a15 /include/package-defaults.mk
parentb9d87db64f9474ab1a4cd505ba5535bc328c7619 (diff)
downloadmaster-187ad058-fd0fbff63dbbb7fb2e41a2612922ccd65006517f.tar.gz
master-187ad058-fd0fbff63dbbb7fb2e41a2612922ccd65006517f.tar.bz2
master-187ad058-fd0fbff63dbbb7fb2e41a2612922ccd65006517f.zip
package-defaults.mk: set DISABLE_NLS only if not CONFIG_BUILD_NLS
set DISABLE_NLS only if CONFIG_BUILD_NLS NOT set. like DISABLE_IPV6 which depends on CONFIG_IPV6 Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44930 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 9567e04a7a..e37ab88a31 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -67,7 +67,11 @@ ifneq ($(strip $(PKG_UNPACK)),)
endif
EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
-DISABLE_NLS:=--disable-nls
+ifeq ($(CONFIG_BUILD_NLS),y)
+ DISABLE_NLS:=
+else
+ DISABLE_NLS:=--disable-nls
+endif
CONFIGURE_PREFIX:=/usr
CONFIGURE_ARGS = \